Symptom
- You're receiving error when trying to access 'My Quotes' page in your CPQ tenant.
Error: Sorry for the inconvenience, but there seems to be an error in the system (Error code: <error code>). An automatic notification has been sent our way and we'll be fixing the error as soon as possible. In the meantime you can go back to the login page and continue working in SAP CPQ. - But you can access 'Other Quotes' page without any issues.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Login to CPQ
- Click on Load Quotes button
- Go to My Quotes.
Cause
- The error in the Developer Console log, and in the Logs page, says "Specified cast is not valid".
- This means that the issue was caused by changing the 'type' of the custom field which is normally forbidden from the UI.
- To fix this, we need to execute a DB query which will convert the current custom field value in the proper format.
Resolution
Please create an incident to SAP CPQ Support team with the error message, and we'll have this issue fixed by executing a DB query on your tenant, internally.
See Also
3300146 - How to contact SAP CPQ Support team?
Keywords
my quotes page, error, custom field, Specified cast is not valid, custom field , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions