SAP Knowledge Base Article - Public

3437913 - Error by Adding Customer to existing BusinessPartner Using SOAP BusinessPartnerSUITEBulkReplicateRequest_In

Symptom

Customer met an error "Entry BP does not exist in TPAR" when used the API BusinessPartnerSUITEBulkReplicateRequest_In.

Environment

SAP S/4HANA cloud

Cause

The rootcause is the partner function.

As the payload shows, customer is sending the English keys for the partner function.

Resolution

The SOAP inbound expect the German keys not English. Please try to adjust the keys in the payload and try it again.

For example:

DE    AG    AG
DE    AP    AP
DE    AZ    ZA
DE    BA    BA
DE    ED    ED
DE    EK    EK
DE    EN    EB
DE    LF    LF
DE    LW    LW
DE    RE    RE
DE    RG    RG
DE    RP    RP
DE    RS    RS
DE    SB    SB
DE    SP    SP
DE    VA    VA
DE    VE    VM
DE    WE    WE
DE    WL    WL
DE    ZM    ZM

EN    AG    SP
EN    AP    CP
EN    AZ    AP
EN    BA    OA
EN    ED    ED
EN    EK    BU
EN    EN    EU
EN    LF    VN
EN    LW    DP
EN    RE    BP
EN    RG    PY
EN    RP    RP
EN    RS    PI
EN    SB    SB
EN    SP    CR
EN    VA    CA
EN    VE    SE
EN    WE    SH
EN    WL    GS
EN    ZM    ER

Keywords

BusinessPartnerSUITEBulkReplicateRequest_In, SOAP API, partner function , KBA , LO-MD-BP-WS , Web Service for Business Partner , Problem

Product

SAP S/4HANA Cloud Public Edition 2402