SAP Knowledge Base Article - Public

3437913 - Error by Adding Customer to existing BusinessPartner Using SOAP BusinessPartnerSUITEBulkReplicateRequest_In

Symptom

Customer met an error "Entry BP does not exist in TPAR" when used the API BusinessPartnerSUITEBulkReplicateRequest_In.

Environment

SAP S/4HANA Cloud Public Edition

Cause

The rootcause is the partner function.

As the payload shows, customer is sending the English keys for the partner function.

Resolution

The SOAP inbound expect the German keys not English. Please try to adjust the keys in the payload and try it again.

For example:

Language KeyPartner Function(Interface Used)Lang-spec.part.func(UI Display)
DEAGAG
DEAPAP
DEAZZA
DEBABA
DEEDED
DEEKEK
DEENEB
DELFLF
DELWLW
DERERE
DERGRG
DERPRP
DERSRS
DESBSB
DESPSP
DEVAVA
DEVEVM
DEWEWE
DEWLWL
DEZMZM
   
ENAGSP
ENAPCP
ENAZAP
ENBAOA
ENEDED
ENEKBU
ENENEU
ENLFVN
ENLWDP
ENREBP
ENRGPY
ENRPRP
ENRSPI
ENSBSB
ENSPCR
ENVACA
ENVESE
ENWESH
ENWLGS
ENZMER

Keywords

BusinessPartnerSUITEBulkReplicateRequest_In, SOAP API, partner function , KBA , LO-MD-BP-WS , Web Service for Business Partner , Problem

Product

SAP S/4HANA Cloud Public Edition 2402