SAP Knowledge Base Article - Public

3438008 - Error KD256 "There are no accrued amounts; settlement is not possible" raised in order settlement

Symptom

When performing order settlement, encounter error "KD256: There are no accrued amounts; settlement is not possible".
However, there's still balance exist in order and order cannot be closed.

Environment

SAP S/4HANA Cloud

Cause

There are possibly some reasons cause this error, for example:

  1. There's no amount posted at all in that settlement period, thus nothing canbe settled or The settlement of that period has already been done, thus cannot be settled again.
  2. The status of TECO/DLV was set in a later period(later than settlement period), thus only WIP can be settled, variance can only be settled in next period(TECO/DLV active date) to clear the order balance.

Resolution

For reason 1, kindly check the order postings, for example, use APP 'Display Line items - Production Accounting',
check which period has remaining values, and settle the order using that settlement period.
For reason 2, if the variance cannot be settled due to TECO/DLV status not set within current settlement period,
kindly check the order status date via APP 'Display Production Orders(CO03), click 'More'->'Header'->'Status Changes'.
Find the TECO/DLV date set in which period and settle the remaining balance in the future period.
If you still want to settle it in current period and if it's still possible to change the DLV status(since TECO status cannot be set to a previous date),
DLV status has higher priority than TECO, you can try to reverse the Final Goods Receipt posting and repost it with current period posting date to make DLV active in current period, then try to settle it in current period.

Keywords

Order settlement, KD256, There are no accrued amounts; settlement is not possible, DLV, TECO, Order balance, unable to close order. , KBA , CO-PC-OBJ-ORD-2CL , Product Cost by Order (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions