Symptom
User's are receiving "Synchronization was skipped" sync message in Groupware Settings.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to E-Mail Integration
- Go to Groupware Settings
- Go to User's
- Select any User
- The Message "Synchronization was skipped" is received
Cause
A new feature "Adaptive Sync Session Interval" had been introduced.
Resolution
By default, the adaptive sync session intervals are calculated following this pattern:
- T+0:00 Run a sync
-
T+0:30 Run a sync
If changes are detected, the pattern will restart from step 1 (ensuring the user syncs every 30 mins).
If no changes are detected, the next sync session will be skipped. The sync will occur in 60 minutes.
-
T+1:30 Run a sync
If changes are detected, the pattern will restart from step 1
If no changes are detected, the next 3 sync sessions will be skipped. The next sync will be in 120 minutes.
-
T+3:30 Run a sync
If there are changes detected, the pattern will restart from step 1.
If no changes are detected, the pattern of skipping 3 out of 4 sync sessions will repeat until any changes are detected or the adaptive sync interval resets.
Also, the sync is not skipped when a user performs saving operations via Add-in.
Keywords
Server-Side, Outlook, Sync, Skipped, Users, , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem