Symptom
Searching using Sales Territory ID in Phone Call Advance Filter returns no/unexpected results.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
Pre-Requisite: You have a Customer ABC which has a Sales Territory ID XYZ maintained under Sales Territory Facet and this customer is maintained in the Phone Call Activity 123 (ABC represents the Customer ID ; XYZ represents the ID of the Sales Territory ; 123 represents the Phone Call ID).
Steps:
- Go to Activity Work Center
- Go to Phone Call View
- On the Advance Filter enter Sales Territory ID XYZ
- Click on Go
You notice there is either no results/not expected result as the phone call 123 with the customer ABC maintained is not displayed.
Cause
The search result does not check the Sales Territory data maintained for an Account when you are filtering in the Phone Call BO. When searching using Sales Territory ID inside Phone Call BO, the search results are displayed based on the Sales Territory maintained at the header level of the Phone Call Activity.
In your case, for the Phone Call the Sales Territory has ID DEF maintained in the header section (DEF is the ID of another Sales Territory). Hence searching using Sales Territory ID XYZ does not return the expected result.
Resolution
This is system expected behavior. Please filter based on the Sales Territory ID maintained at the header level of the Phone Call Activity for the correct results.
In this case you can search using Sales territory ID DEF and you will find that the Phone Call 123 is the result which is the expected behavior.
Keywords
Phone Call , Sales Territory , Customer , No Result , Advance Filter , Incorrect result , unexpected result , KBA , LOD-CRM-ACT , Activities , LOD-CRM-LA , Live Activity , How To