Symptom
You have hired an employee through the non-localized tab, however it is not possible to assign the International Time Accounts to them.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Time Administration work center.
- Go to Employees view.
- Search for the relevant employee.
- Edit.
- Go to Time Profile tab.
- Go to Time Account Rules subtab.
- Click Add Row.
- You will see 'No items found' message.
Cause
Although you have hired this employee through one of the options in the non-localized dropdown, the country you selected is actually a localized country in SAP Business ByDesign.
This dropdown is the same one used in every country/region selection in the system, so all countries are displayed - not only the non-localized ones.
Each localized country has its own specific Time Accounts, and it is not possible to make the International Time Accounts available for employees from localized countries (even if this country is not scoped in your tenant).
Below is the list of localized countries in SAP Business ByDesign. If the employee is hired in one of these countries, the Time Accounts for this respective country must be used - it is worth noting that they will only be available if this country is scoped in the tenant.
- Australia
- Austria
- Belgium
- Canada
- China
- Denmark
- France
- Germany
- India
- Israel
- Italy
- Japan
- Mexico
- Netherlands
- New Zealand
- South Africa
- South Korea
- Spain
- Switzerland
- United Kingdom
- United States
Resolution
You need to use the Time Accounts which are specific to a localized country. If the employee is indeed hired in a non-localized region, the International Time Accounts will then be available.
Keywords
time accounts international, not able to assign time accounts, time accounts not working, no records found , KBA , SRD-HR-TLM , Time and Labour Management , Problem