Symptom
- You are using the OData API API_CV_ATTACHMENT_SRV within a Custom Communication Scenario. You must be able to work with attachments (read, delete or create new attachments) as part of your Custom Communication Scenario
- This feature is only available when Feature Toggle: CUSTOM_COM_SCEN_API_PILOT is activated.
Environment
- Document Management ( DMS )
Cause
Please check the KBA 3439117 - Activating Released SAP Inbound Services for Use in Custom Communication Scenarios
Resolution
When you include the Attachments API in a Custom Communication Scenario, ensure you also include the API of the leading business application. This ensures that the authorization objects from the leading business application are accessible in the Custom Communication Scenario for all the Attachment operations. The Attachments API allows the leading business application to handle the business authority checks.
If you are working with DMS Attachments, then you must maintain the authorization objects listed below:
- C_DRAD_OBJ
- C_DRAW_DOK
- C_DRAW_STA
- C_DRAW_TCD
- C_DRAW_TCS
For maintenance of these authorizations object in the context of the leading business application, refer to the sample note 3430638- OData API API_SUPPLIERINVOICE_PROCESS_SRV: Attachment handling with custom communication scenario
Keywords
Custom Communication Scenario, Attachments, CUSTOM_COM_SCEN_API_PILOT , KBA , CA-DMS , Document management , How To