SAP Knowledge Base Article - Public

3439145 - BADI not triggered when using Reply with Outlook

Symptom

BADI not triggered when using Reply with Outlook

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service - Ticket
  2. Go to interactions tab, click on Reply
  3. Notice the subject starts with custom pattern implemented in the BADI ManageEmailSubjectPrefix
  4. Click Reply with Outlook
  5. Notice the pattern - [ Ticket: 12345 ] - this is standard pattern, BADI is not working in this case.

Cause

Such Badi was created only to be used in the internal feeder, this means the Interactions and Timeline internal email editor. It cannot be called together with external email editor (Outlook). 

Resolution

  • If you need the function, you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
    You can find more details about the services offered by Cloud Service Center on.
  • If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
  • If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page 
    Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
  • An alternative option may be to check the SAP Customer Influencer Site to submit an idea: https://influence.sap.com/sap/ino/#/campaign/903 

Keywords

KBA , LOD-CRM-SRP-INT , Ticket Interactions , Known Error

Product

SAP Cloud for Customer core applications all versions