SAP Knowledge Base Article - Public

3439950 - Unable to Update Service Category by Data Workbench

Symptom

You try to update the Service Category by Data Workbench for tickets which are Completed. Error message: "Changing Service Category not possible; field is read-only".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Data Workbench work center
  2. Go to the Import view 
  3. Select Individual Object
  4. Select Update and tick the User Known IDs box
  5. Select an object as the Standard Object
  6. Search Service Request
  7. Click Next
  8. Upload the file that the Service Category is different to the current Service Category for the Ticket 123 (Where 123 refers to the Ticket ID and the ticket is Completed status)
  9. Select All Data for the Format Validation
  10. Click Next
  11. Click Import
  12. Go to the Monitor view
  13. Check the Task

Result: There is 1 in Errors

Cause

The Service Category cannot be updated by Data Workbench for tickets which are Completed and Closed status. This is an expected system behavior.

Resolution

If you want to change the Service Category, change the ticket status to the status other than Completed or Closed. (e.g. In Process)

See Also

As per KBA 3439932 - Incident Category & Cause Category are Updated for Tickets with Completed and Closed Status, the Incident and Cause Categories can be updated even if a ticket status is Completed and Closed. The Service Category and the Incident & Cause Categories are set up differently so you observe different behaviours, but both expected system behaviors.

Keywords

data workbench, import, ticket, service category, completed, closed, status, field, read-only , KBA , LOD-CRM-SRP-API , Ticket API & Odata , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications 2402