SAP Knowledge Base Article - Public

3440450 - Cannot Assign Down Payments to the External Customer Invoice Request created via webservice

Symptom

When the user creates the External Customer Invoice request via webservice Managecustomerinvoicerequestin, it is not possible to assign the down payments because Assign Down payments button is missing. 

Environment

SAP Business Bydesign

Reproducing the Issue

  1. Go to Customer Invoicing Work center
  2. Go to Invoice Requests View
  3. Select Show All Invoice Requests from Drop down
  4. Search for External Customer Invoice Request XYZ which is in status To be Invoiced.(XYZ is the ID of the External Customer Invoice Request)
  5. Click on Edit button and then in the Invoice request Screen Click on View All Button
  6. Assigned Down payments section is not visible under the General tab.

Cause

Whenever you create a invoice request via webservice which has both Invoice item and Credit Memo item, it is not possible to assign the Down Payment Requests. Assign Down Payments is available only when you create the External Customer Invoice Request with Invoice Items only. It is not available when you create the External Customer Invoice Request with only Credit Memo items or Both Invoice and Credit Memo Item.

Resolution

This is the current system behavior.

Keywords

External Customer Invoice Request; Assign Down Payments; Credit memo item; , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign all versions