Symptom
- The "From" email address for a class notification is different than the standard one configured on "Global Application Settings" > "Mail" tab.
- How to configure email notifications from Global Application Settings(Application Notification email ID) even though the "Contact address" field is updated with an instructor email ID at the class level?
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Enroll a user to a class >
- The User receives enrollment notification but with a different "From" address than standard one.
Cause
When a class has an user configured as "Class Contact" and the "Always use Application Admin's email address as the From address on Vcalendar attachments:" flag is checked on System Administration > Configuration > Global Application Settings > Edit Global Application Settings > Mail Settings, the notification will pull the "Class Contact" email as the "From" address.
Resolution
To ensure mail delivery from the Global Application Mail Settings, enable the option "Always use Application Admin's email address as the From address on Vcalendar attachments:".
This configuration can be found on the following path:
- Access "Learning Administration" >
- Go to "System Administration" >
- Access the "Configuration" section>
- Reach "Global Application Settings" >
- Click to "Edit" Global Application Settings >
- Access the "Mail" settings tab >
- Select checkbox "Always use Application Admin's email address as the From address on Vcalendar attachments:" configuration.
Keywords
SuccessFactors, Learning, Notification, email, class, contact, global, application, settings, mail, section, enroll, , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS , Learning Management System , Problem