Symptom
- The "From" email address for a class notification is different than the standard one configured on "Global Application Settings" > "Mail" tab.
- How to configure email notifications to use the "Application Notification email ID" from Global Application Settings as the "from" address, even though the "Contact address" field at the class level is populated?
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Learning Administration >
- Classes >
- Open one Class record >
- Configure an email address under the Contact Email Address field >
- Enroll a User to the Class >
- The User receives an enrollment notification with a different "From" address than the standard one.
Cause
When a class has an email address configured under "Contact Email Address" and the "Always use Application Admin's email address as the From address on Vcalendar attachments" flag is unchecked on System Administration > Configuration > Global Application Settings > Edit Global Application Settings > Mail Settings, the notification will pull the "Class Contact" email as the "From" address.
Resolution
To ensure that the emails are sent using the Admin email address set on Global Application Settings, enable the option "Always use Application Admin's email address as the From address on Vcalendar attachments".
This configuration can be found on the following path:
- Access "Learning Administration" >
- Go to "System Administration" >
- Access the "Configuration" section>
- Reach "Global Application Settings" >
- Access the "Mail" settings tab >
- Select the checkbox for "Always use Application Admin's email address as the From address on Vcalendar attachments" configuration >
- Click on 'Apply Changes'.
Keywords
SuccessFactors, Learning, Notification, email, class, contact, global, application, settings, mail, section, enroll, vcal, from, sender , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS-SCH , Class - Scheduled Offerings , Problem
SAP Knowledge Base Article - Public