Symptom
User wants to update New dunning Procedure code field via webservice after creation of Account.
Environment
SAP Business ByDesign
SAP Cloud for Customer
Reproducing the Issue
- Go to Account Management WorkCenter View.
- Navigate to Accounts view.
- Select Account ID.
- Select Edit.
- Navigate to Financial Data Tab.
- Choose Payment Data.
- Navigate to "Dunning" field.
- User wants to update New dunning field via webservice.
Cause
Field can be updated by using webservice "Manage Trade Receivables Payables Accounts".
Resolution
User can use webservice "Manage Trade Receivables Payables Accounts" , pass company and business partner ID to update new dunning field.
Below is a simple example of an update message
NOTE: In below payload XXXXXX refers to company ID and YYYYYY refers to Business Partner ID.
<n0:TradeReceivablesPayablesAccountBundleMaintainRequest_sync xmlns:n0="http://sap.com/xi/SAPGlobal20/Global">
<TradeReceivablesPayablesAccount actionCode="02">
<CompanyID>XXXXXX</CompanyID>
<BusinessPartnerInternalID>YYYYYY</BusinessPartnerInternalID>
<NettingBlockedIndicator>true</NettingBlockedIndicator>
<DebtorDoubtfulIndicator>true</DebtorDoubtfulIndicator>
<DunningBlockedIndicator>true</DunningBlockedIndicator>
<DunningBlockingExpirationDate>yyyy-mm-dd</DunningBlockingExpirationDate>
<DunningBlockingReasonCode>02</DunningBlockingReasonCode>
<NewDunningProcedureCode>03</NewDunningProcedureCode>
</TradeReceivablesPayablesAccount>
</n0:TradeReceivablesPayablesAccountBundleMaintainRequest_sync>
See Also
Keywords
New dunning field, account management, dunning strategy, ManageTradeReceivablesPayablesAccountIn , KBA , SRD-MD-BP , Business Partner , Problem