SAP Knowledge Base Article - Public

3441185 - Avoid popup when working with multiple C4C sessions connected to unique CTI widget

Symptom

Popup from CTI widget is affecting ALL C4C sessions opened (it is appearing at foreground)

Environment

  • SAP Service Cloud
  • Live Activity
  • SAP Cloud for Customer

Reproducing the Issue

  1. Login at C4C
  2. Click on telephone icon
  3. Enter credentials to login at your CTI
  4. Open several C4C sessions or even open new Internet browsers Windows
  5. Work on any session
  6. As soon as you receive an incoming action from CTI widget (call, e-mail, etc), CTI widget is opened requesting an action
  7. When changing to another C4C session, such CTI widget popup remains at the same position

Cause

CTI widget popup affects ALL browser sessions (it is appearing at foreground)

Resolution

You can apply the following workaround which allow you to receive CTI widget notification at Operating system level, instead of raising a CTI popup window

Customization is required at Operating System level and at Internet browser (here we are providing the instructions for Google Chrome browser, but it can be done for other ones)

  • Operating System level:
    1.      Search "Notifications & Actions"
    2.      Enable "Notifications"
  • Internet browser (instructions for Google Chrome):
    1. Open Google Chrome
    2. Click on Three dots (right upper corner)
    3. Select Settings
    4. Search "Notifications"
    5. Expand "Site Settings"
    6. Under "Permissions", expand "Notifications"
    7. At "Allowed to send notifications" click on Add button
    8. Add your widget CTI URL
    9. Once created, check if Permissions for "Notifications" is "Allow"

Keywords

popup foreground background avoid notification multiple session widget CTI , KBA , LOD-CRM-LA , Live Activity , How To

Product

SAP Cloud for Customer core applications 2402