SAP Knowledge Base Article - Public

3441596 - Update Custom Field value through API

Symptom

Using Quote Items API with body to update custom field does not work.

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Use below API with POST:

URL: https://TENANTNAME.cpq.cloud.sap/api/v1/quotes/{{quote_id}}/items
body:

[
  {
    "Quantity": 8,
    "ProductSystemId": "XX_XXXX",
    "ExternalConfigurationId": "{{configuration_id}}",
    "CustomFields": [
        {
            "Name": "SalesDesciption",
            "Content": "xxxx"
        }
    ]
  }
]

Cause

Expected behavior, it is not possible to update custom field through the Quote Items API.

Resolution

Item can be created through POST /api/v1/quotes/{quoteId}/items and later on use the following API to update value of Quote Item Custom Field: PATCH /api/v1/quotes/{quoteId}/items/{itemId}

Other alternative is to create script to update multiple items and exposte it through Custom API.

Keywords

API, Payload, Body, Items, Quotes, Patch, Post, CPQ. , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To

Product

SAP CPQ all versions