SAP Knowledge Base Article - Public

3441885 - Unable to modify the 'Access' in existing OAuth Client in SAP Analytics Cloud (SAC).

Symptom

The 'Access' option is disabled when trying to modify it in an existing OAuth Client in SAC.

Environment

SAP Analytics Cloud

Reproducing the Issue

  1. Login to SAC.
  2. Go to System -> Administration.
  3. Choose the App Integration tab.
  4. Under Configure clients, click on Edit OAuth client.

    Notice that there is no ability to add or remove the list from the 'Access' field.

Cause

This behaviour is by design.

Resolution

Once an OAuth client has been configured, it cannot be edited.

See Also

Keywords

API, Multi Actions, OAuth Client, RestAPI, SAC, events, access, Interactive Usage and API Access, token, secret , KBA , LOD-ANA-ADM , SAC Administration , Problem

Product

SAP Analytics Cloud all versions