Symptom
The 'Access' option is disabled when trying to modify it in an existing OAuth Client in SAC.
Environment
SAP Analytics Cloud
Reproducing the Issue
- Login to SAC.
- Go to System -> Administration.
- Choose the App Integration tab.
- Under Configure clients, click on Edit OAuth client.
Notice that there is no ability to add or remove the list from the 'Access' field.
Cause
This behaviour is by design.
Resolution
Once an OAuth client has been configured, it cannot be edited.
See Also
- https://help.sap.com/doc/00f68c2e08b941f081002fd3691d86a7/2022.12/en-us/4f43b54398fc4acaa5efa32badfe3df6.html
- https://help.sap.com/docs/SAP_S4HANA_CLOUD/0f69f8fb28ac4bf48d2b57b9637e81fa/ddbc64b5c7d64892ad9f848e91a8b45e.html
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Keywords
API, Multi Actions, OAuth Client, RestAPI, SAC, events, access, Interactive Usage and API Access, token, secret , KBA , LOD-ANA-ADM , SAC Administration , Problem
Product
SAP Analytics Cloud all versions