SAP Knowledge Base Article - Public

3442644 - Approval Process is not Triggered for Customer Invoice created for a Sales Order.

Symptom

You have enabled the approval for Customer Invoice and defined the approval process. However, when you release a Customer Invoice for a Sales Order via the Outbound Delivery Invoice Request or Sales Order Invoice Request, the approval process is not triggered. The invoice is created and released directly.

The same applies for Credit Memos that are based on a preceding document. 

Environment

SAP Business Bydesign

Reproducing the Issue

  1. Go to Customer Invoicing work center
  2. Go to Invoice Documents
  3. Search for Invoice XXX(XXX is the ID of the Customer Invoice)
  4. You can see approval status is Approval not necessary
  5. However you have set up the approval process for customer invoicing, you expect the Customer Invoice to go Approval.

Cause

The Approval for Customer Invoicing only applies to Invoices or Credit Memos that are based on a Manual Invoice Request or Manual Credit Memo Request.

If an invoice is based on a preceding document such as a Sales Order the Approval Process for Customer Invoices will not be triggered and the document is not sent for Approval..

The reason for that is that you can set up approval processes for these documents e.g. Sales Orders the approval should already happen at this stage.

 

Resolution

This is the expected system behaviour.

If you require Approval for all Business Processes ending in Customer Invoicing, you can set up Approvals for the preceding document, for example the Sales Order or Return, so that you can control the information that is derived on the Customer Invoice or Credit Memo.

 

Keywords

Sales Order request, approval, no approval task, outbound delivery invoice request; , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign all versions