Symptom
After recent S/4 HANA upgrade, following authorization error suddenly popped up while previewing certain remote tables built on CDS views via CDI connection:
internal error: connection to <S/4 HANA Cloud API Server>:443 returned status 403 message: {"error":{"code":"/IWBEP/CM_MGW_RT/000","message":{"lang":"en","value":"You do not have start authorization for R3TR IWSV YY1_I_CDSVIEWNAME_CDS 0001, return code 4"},"innererror":{"application":{"component_id":"","service_namespace":"/SAP/","service_id":"YY1_I_CDSVIEWNAME_CDS","service_version":"0001"},"transactionid":"xxxxxxxxxx","timestamp":"xxxxxxxxxxxx","Error_Resolution
Issue could also occur when replicating remote table.
Environment
SAP Datasphere
Cause
The authorization groups in communication arrangements were not there from the beginning.
In earlier times it was possible to create communication arrangements without authorization groups.
May be the case, the authorization groups were introduced at a time when the communication arrangement was already created.
The introduction of authorization groups was necessary because at that time colleagues in Datasphere wanted to replicate CDS views that were more sensitive than other CDS views via CDI OData (SAP_COM_0531).
Therefore, the authorization groups were added.
The existing arrangement was running without forcing to enter an authorization group. This has now stopped working with the upgrade to S/4HANA 2402.
Resolution
The easiest and fastest way to fix this problem is to enter the authorization group.
See Also
SAP Datasphere Help Portal Prepare Connectivity to SAP S/4HANA Cloud
Keywords
KBA , BW-WHM-DBA-ODA , Operational Data Provider for ABAP CDS, HANA & BW , DS-DI-RT , Remote Tables , DS-DI-CON , Connections , Known Error