Symptom
You open up the Administration Console and notice that some settings are missing. These settings may be showing for other users in your tenant or with same user in another tenant.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Click on your User Icon and open Settings.
- Choose All Settings.
- You search for a specific setting but no results are shown.
Cause
This is an access related issue. You must have the correct services applied and enabled to the business role of the logged on user.
If the relevant service is not assigned to the business role, The associated setting will disappear from the Administration Console screen.
Resolution
Lets take an example.
You open up the Administration Console and search for "Users". You get message "No matching results found".
The resolution would be:
- Open up the business role which is assigned to your user.
- Under business services, search for "Users". If no results appear, you need to add it. Click the + button and search again. You will get result for Users (sap.crm.service.userService).
- Once added, you need to scroll down to App List. Here you search for "Users" again and the app will appear. You need to also enable this.
- Then refresh the system. You should now be able to see the Users option in Settings.
This example applies to all settings. If a setting does not appear, there should be a relevant service which is not assigned to the user andsame steps must be taken.
Keywords
Setting, Settings, Missing, Appearing, No matching results found, User, Administrator, Admin , KBA , CEC-CRM-IAM , Identity and Access Management for SAP Sales/Service Cloud , Problem
Product
Attachments
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SAP Knowledge Base Article - Public