SAP Knowledge Base Article - Public

3444008 - Inheritance of the field Country/Region in Lead conversion

Symptom

When converting a Lead to an Opportunity, the Country/Region field is converted with it.

Environment

Cloud for Customer

Reproducing the Issue

  1. Go to Sales WC
  2. Go to Leads View
  3. Click on Create new lead
  4. Fill out the required fields and save to create the Lead
  5. Convert to Opportunity
  6. Check the account created at the same time as the opportunity was created.
  7. Notice in the tab (Address), there is the country that was inherited since creating the Lead
  8. Change this field to a different Country. In this case, it will be US – Estados Unidos, and Save.
  9. Create a new Lead
  10. Notice that automatically, also after filling out the field “Company”, the Country/Region is automatically set as “US-Estados Unidos”. This was the last change made to customer ABC, created in previous steps.

Cause

The country/region used by an user while creating / changing any business partner address will be the country/region which will be defaulted the next time this user creates a new business partner address.

Resolution

This is a designed system behavior.

Keywords

Country, Region, field, Lead, Opportunity, Account, Address, Converting  , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer core applications 2402