Symptom
When converting a Lead to an Opportunity, the Country/Region field is converted with it.
Environment
Cloud for Customer
Reproducing the Issue
- Go to Sales WC
- Go to Leads View
- Click on Create new lead
- Fill out the required fields and save to create the Lead
- Convert to Opportunity
- Check the account created at the same time as the opportunity was created.
- Notice in the tab (Address), there is the country that was inherited since creating the Lead
- Change this field to a different Country. In this case, it will be US – Estados Unidos, and Save.
- Create a new Lead
- Notice that automatically, also after filling out the field “Company”, the Country/Region is automatically set as “US-Estados Unidos”. This was the last change made to customer ABC, created in previous steps.
Cause
The country/region used by an user while creating / changing any business partner address will be the country/region which will be defaulted the next time this user creates a new business partner address.
Resolution
This is a designed system behavior.
Keywords
Country, Region, field, Lead, Opportunity, Account, Address, Converting , KBA , LOD-CRM-LM , Lead Management , Problem
Product
SAP Cloud for Customer core applications 2402