SAP Knowledge Base Article - Public

3444334 - Error "Customer/vendor does not have suitable bank details for payment method &"

Symptom

The error "Customer/vendor does not have suitable bank details for pmnt method &" occurs when reallocating the payment method for a journal entry in the payment proposal within app "Manage Automatic Payments".

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP S/4HANA CLOUD

Cause

This error message typically arises due to a customizing issue. This may be because no bank details have been entered in the customer/vendor master record, or the bank details that have been entered cannot be utilized with the inputted payment method.

Resolution

  1. Go to app "Maintain Business Partner"
  2. Enter business partner and click on "Start"
  3. Select "Supplier (Fin.Accounting)" for "Display in BP Role"
  4. Click on button "Company Code" on the top menu
  5. Switch to tab "Vendor: Payment Transactions"
  6. Fill bank data in section "Automatic Payment Transactions"

Keywords

manage automatic payments, revise payment proposals, bank details, reallocate , KBA , FI-AP-AP-B-2CL , Payment Progam / Payment transfer (DE, JP, US) (Public Cld) , FI-FIO-AP-PAY-2CL , Payment Apps (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions