Symptom
You are trying to change the Service Start Date of an Employee, however, an error occurs:
"Save failed
Time account XXX assigned. Change of service start date not possible.
Time account YYY assigned. Change of service start date not possible.
Time account ZZZ assigned. Change of service start date not possible."
Where XXX, YYY and ZZZ represent the Time Accounts' names.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Personnel Administration work center.
- Go to Employees view.
- Search for the relevant Employee ID.
- Click Edit.
- Go to Employment tab.
- Then change the Service Start Date.
- Click Save.
- Errors occur.
Cause
The Time Accounts assigned to this Employee need to be removed before changing the Service Start Date.
Resolution
Remove the Time Accounts assigned to this Employee by following below steps:
- Go to Time Administration work center.
- Go to Employees view.
- Search for the relevant Employee ID.
- Click Edit.
- Go to Time Profile tab.
- Go to Time Account Rules sub-tab.
- Remove all Time Accounts.
Now, change the Service Start Date of the Employee.
After that, you may assign the Time Accounts back.
If after performing this whole process the error still happens, please open a case with SAP Product Support providing the following info:
- Employee ID affected.
- Which Service Start Date you wish to be displayed (DD/MM/YYYY).
- Authorization to change the Service Start Date.
- Authorization to remove the Time Accounts from UI.
- Authorization to perform a backend correction (in case there is any inconsistency in master data after the Time Accounts are removed).
Keywords
service date, service data, start date, rehired, employee rehired , KBA , SRD-HR-PAD , Personnel Administration , Problem