Symptom
You are checking the Access Group ID for a Business Role under Access Restrictions tab and some of the options are listed as Invalid Access Group.
Environment
- SAP Business ByDesign
- SAP Cloud for Customer
Reproducing the Issue
- Go to Application and User Management Work Center (SAP Business ByDesign) or Administrator Work Center (SAP Cloud for Customer).
- Go to Business Roles View.
- Select the Business Role affected.
- Click on Edit button.
- Go to the Access Restrictions tab.
- Select the Work Center View ID affected.
Under Details Restrictions some of the Access Group ID are listed as Invalid Access Group.
Cause
The Org Unit referenced by the Access Group ID was deleted or is no longer valid in the system. Therefore, to ensure the system consistency it displays the Invalid Access Group as reference for those Org Units, hence this is the expected system behavior.
Resolution
For this case, we recommend to remove the Invalid Access Group options by unchecking the Invalid Access Group and saving the changes in the business role, as it is only being displayed as a reference to the Org Unit that is not available in the system anymore.
To remove the Invalid Access Group options follow the below steps:
- Go to Application and User Management Work Center (SAP Business ByDesign) or Administrator Work Center (SAP Cloud for Customer).
- Go to Business Roles View.
- Select the Business Role affected.
- Click on Edit button.
- Go to the Access Restrictions tab.
- Select the Work Center View ID affected.
- Uncheck the Invalid Access Group option.
- Click on Save.
The Invalid Access Group will not be displayed in the UI for the Work Center View ID of the business role.
Keywords
byd, c4c, Invalid Access Group, Business Role, Work Center ID , KBA , SRD-CC-IAM , Identity & Access Management , How To