SAP Knowledge Base Article - Public

3445853 - Signature Button in Create Email Screen Does Not Display Signatures

Symptom

You notice that, upon clicking on the Signatures button in the Create Email screen for any object e.g. Appointment, nothing happens and the signatures are not displayed.

Environment

SAP Service Cloud Version 2.

Reproducing the Issue

Using appointments object as example:

  1. Navigate to Activity Manager work list.
  2. Open any appointment.
  3. Click on the Email icon next to the Appointment Invitees section.
  4. In the Create Email pop-up, click on the Signature button.
  5. See nothing happens and the signatures are not displayed.

Cause

A possible cause for the signatures not to be displayed is that the user does not have access to the business service Template - sap.crm.service.templateService and sap.crm.templateservice.uiapp.template App in their business role.

Resolution

To adjust this and ensure the user can access the signatures, email templates and branding templates, you can follow the steps below:

  1. Click on the User Menu.
  2. Click Settings.
  3. Navigate to All Settings.
  4. Click Users under Users and Control.
  5. Search for the affected user and open it.
  6. Navigate to Assigned Business Roles tab.
  7. Open the role.
  8. Under Business Services section, click +.
  9. Search for Template.
  10. Select it and click Add.
  11. Under the App List, enable the sap.crm.templateservice.uiapp.template app

Keywords

Template, Email, Signature, Signature Template, Branding Template, Email Template, Button, Results, Appointment, Object, Create Email, Email, sap.crm.templateservice.uiapp.template, sap.crm.service.templateService, SAP Service Cloud Version 2, V2, SAP Sales Cloud Version 2, , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions ; SAP Service Cloud Version 2 all versions