SAP Knowledge Base Article - Public

3445896 - An assignment block missing in service contracts or solution orders - SAP S/4HANA Cloud Public Edition

Symptom

When trying to add an assignment block to the object page of a service contract or a solution order via the personalization option, the option is not listed within the Displayed Assignment Blocks.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the "Manage Service Contracts" or "Manage Solution Orders" App.
  2. Click on the Personalization icon.
  3. Within the Displayed Assignment Blocks the user needs to enable one entry.
  4. This entry is missing.

Cause

With S/4HANA Cloud Public Edition release 2602, SAP delivered changes to the UX behavior. As part of these enhancements, certain assignment blocks are no longer delivered as default visible blocks. Instead, they are now controlled via UI Personalization / Adapt UI. This is an expected design change introduced with the 2602 release.

Resolution

Take the "Notes" assignment block as an example. It can be added to the personalization screen by following the below steps:

  1. Click 'Adapt UI' button.
  2. Scroll down the page to bottom blank.
  3. Right click and select "Add section".
  4. Choose the needed assignment block like "Notes" and click OK.
  5. Exit adapt mode.
  6. Click the gear icon.
  7. The user should now be able to enable the display of the "Notes" section.

Keywords

personalise, personalize, personalisation, personalization, price details, tab, screen, view, missing, button, cant find, cant see, not present, hidden, service, service contract, contract, s/4hana. s/4hana cloud, cloud, public, public edition, edition, notes, note, manage service contract, Displayed Assignment Blocks, Assignment Block, solution order, 2602 release, 2602 , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , CRM-S4-SOL-SLO , S4CRM: Solution Order , How To

Product

SAP S/4HANA Cloud Public Edition all versions