SAP Knowledge Base Article - Public

3446031 - Long delays or Time-out issue may happen when saving large stories in SAP Analytic Cloud (SAC)

Symptom

  • In SAP Analytic Cloud (SAC), you create or update very large (multi-MB) stories but are unable to save your changes or saving takes minutes
  • The delays are eliminated if you disable all your web browser extensions or if you connect your laptop from outside your corporate network (e.g. from home)

Environment

  • SAP Analytic Cloud, Enterprise Edition (All versions)

Reproducing the Issue

  1. Create or update a very large story in SAC.
  2. Save the story.
  3. Saving may take multiple minutes or even time out, consistently.
  4. If you run netlog-viewer or other network analysis tools on your network, then you will see BytesSent start high but drop to near zero almost immediately, as per the graph below, or experience other similarly anomalous transmission behavior:

Cause

  • Your IT department could be utilizing Data Loss Prevention (DLP) tools to protect sensitive corporate information. These tools are so common that a Gartner Magic Quadrant has been established for DLP, and Gartner does regular Data Loss Prevention Reviews and Ratings.
  • DLP tools occupy a man-in-the-middle position in your corporate network from which they actively scan web browser content for sensitive information or malign web page content, including:
    • Web browser extensions installed on your laptop
    • Middleware installed in your corporate network
  • Several examples are provided by Gartner in the Reviews and Ratings link above.
  • DLP tools are optimized for scanning web page content for normal web pages sizes but are often not optimized for very large web page sizes and may not perform well, depending on how they are configured. The following table describes observed impacts at various customer sites.

    Story Size

    Impacted

    < 5MB

    Rarely

    5MB to 10MB

    Less frequently

    > 10MB

    More Frequently

  • However, the impact noted above depends on the specific DLP tool and how it is configured, and may not impact all customers, or laptop hardware.

Resolution

If you are trying to save a very large story and it consistently takes minutes or even times out, then:

  1. Check your traffic throughput. Use the netlog-viewer or other network analysis tool approved by your IT department to check your network BytesSent, as per the graph shown above. If the throughput pattern drops as you see above, then DLP interference is likely, so proceed to the next step.

  2. Check for scanner-type web browser extensions. If you see an extension in your web browser that claims to scan every outgoing request or every incoming response or both, then get authorization from your IT department to disable it temporarily and confirm whether that eliminates the delays. If so, then contact your IT department and request that they adjust the DLP configuration or provide a more performant DLP alternative.

  3. Check for corporate DLP middleware. The Reviews and Ratings link above provides a starter list of the top DLP middleware tools, so contact your IT department to confirm if any of these or any other DLP tools are installed on your network. If so, then request that your IT department adjust the DLP configuration or provide a more performant DLP alternative.

    See Also

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    Keywords

    EPM, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Planning, Cloud for Analytics, C4P, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, HCP, C4A, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJ, BOBJcloud, BOCloud., BICloud, BO Cloud, SAC, save, saving, large, big, story, application, content, load, delay, loading, time-out, timeout , KBA , LOD-ANA-DES , Story Design & Visualizations , LOD-ANA-AUT , SAC Authentication / Login , Problem

    Product

    SAP Analytics Cloud 1.0

    Attachments

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