SAP Knowledge Base Article - Public

3446034 - Premise Not Visible In Premise Search

Symptom

Premise not visible in Premise search help on Move-out help on Move-out GAF launched from System TI

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

1. Navigate to Customers Work Center
2. Go to Accounts View
3. Search for an Account number
4. Open the Account and click on the button “Move-out” in the header section
5.The move out GAF pop up will open, on step 1 Customer & Premise, open the search help for Move-out address.
6. In the list of premises shown for possible move-out, Premise XXXXXXX is missing
7. Go to Utilities Work Center
8. Navigate to Premise view and search for Premise XXXXXXX
9. Open the Premise and in Overview tab, under Customer Overview section the Customer shows as an active at this Premise

Cause

If a move-out process is initiated from the Customer TI, while selecting the Premise for Move-out, in the search help for Premise ID

Resolution

To resolve the issue please follow the ISU_FINDER search criteria

1. ISU_FINDER searches for business partners associated with the contract account based on the specified max hits number. In this scenario, the default max hits are set to 100, and we use this information to identify active premises.

2. It fetches the first 100 contract accounts.

3. Then, it retrieves the contracts.

4. The system validates the period, filtering out active contracts.

Additionally SAP have provided a BADI - BADI_COD_UTIL_FINDPREM option to adjust the max hits if needed.

Keywords

ISU- Finder, Utilities BADI, Premise Move out , KBA , LOD-CRM-IND-UTL , Utilities , Problem

Product

SAP Cloud for Customer core applications 2402