Symptom
Custom tokens were created and most of them work. However, for HM/Managers, phone and email address pull through as blank.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Onboarding
Cause
Direct Mapping might not be the correct way to configure custom tokens in this scenario, specially for email address, as Email Information is a collection (multiple values like personal email, business email).
Resolution
With Direct Mapping we don't expect it to work, specially with the Email token (confirmed by engineer team). However with a business rule mapping type it can be achieved. Below we have an example of how to configure it:
- Scenario is Basic, Rule Type needs to be Document Generation:
- Once you have the rule set up, you need to go to Manage Document Template Mapping, where you select Mapping Type as Rule and under Rule select the rule you just created.
Important! As known, the recommendation is to always contact an implementation partner, in order to get the best guidance on customization matters. Support channel is not the appropriate one. We created this article to confirm behavior and to give advices on how to properly achieve the desired scenario, but if any misconfiguration matter, please utilize Partner's channels. Alternately, speak with your Account Executive or Customer Engagement Executive about Professional Services options, or about engaging an SAP Authorized Partner. 2706322 - What is Support – What is Consulting: Cloud Solutions - SAP for Me
See Also
SAP SuccessFactors Onboarding | SAP Community
SAP SuccessFactors | SAP Community
2706322 - What is Support – What is Consulting: Cloud Solutions - SAP for Me
Keywords
custom, token, email, e-mail, phone, business, hiring manager, manager, employee, mapping, map, blank, onboarding, OBX, 2.0 , KBA , LOD-SF-OBX-EML , Notifications , Problem