Symptom
Unable to search for users in Manager field in Quick Action Transfer template.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Configure Transfer template as per documentation by following all the prerequisites Configuring an Employee Central Quick Action Template | SAP Help Portal
- Proxy as one of the Managers. From Homepage, click Manage My Team > For any one of the direct reports, go to Actions > click on Transfer.
- Try to search for any user in Manager field and no results are retrieved.
Cause
This is a Permission Issue. Permission to "Display Name" field is required to be able to search for Manager in the Quick Action template.
Resolution
- Ensure that the user who’s able to perform Transfer action has permissions to Display Name field.
- Go to Manage Permission Roles > Select appropriate Permission Role > Employee Data > provide permissions for Display Name field as per snippet below > Save it. Once saved, users are searchable in Manager field.
NOTE: This functionality is enhanced from 1H 2024 release in which permissions to Display Name field isn't necessary for users to be found in Manager field.
Keywords
Quick Action Template, Transfer, Supervisor, Manager, Search, Unable to search, manager cannot be found. , KBA , LOD-SF-EC-JOB , Job Information , LOD-SF-EC , Employee Central , Problem