Symptom
Onboardee that is a Rehire with Old Employment gets error message at the Personal Data Collection Step - "Looks like something went wrong. Please try again or contact Product Support, if the problem persists."
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as rehire
- Complete PDC
- Error is thrown - Looks like something went wrong. Please try again or contact Product Support, if the problem persists
Cause
Cause 1: One of the cause for this error could be customer has workflow enabled. However, Onboarding does not support workflow on custom objects.
Cause 2: Configured custom objects used in PDC are effective-dated
Resolution
Solution 1:
- Make sure for the customer object, you must set the Show Data Link option to No as currently the support for the workflow is unavailable from Onboarding.
- Please refer to: Configuring UI for the Data Collection Object Entity
Solution 2:
- Update the effective dating settings as per guide: Configuring Hire Template for Access New Hire
- However, such Impact of Changing from "Basic" to "None" are considered:
- Loss of Historical Data: Previous records for the object will no longer be accessible, eliminating the ability to track changes over time.
- Overwriting Data: Any new data entered will replace the existing record rather than creating a new record with a different effective date.
- Reporting and Auditing: Historical data for the object will no longer be available for reporting or audit purposes.
- This issue is occurring only in rehire with old employment cases, not in normal new hire cases.
- In this case, an existing influence idea is created for this - https://influence.sap.com/sap/ino/#/idea/310758
- Please vote as we move to the new Profile UIs for redesigning how configurable new hire works to better support effective dated entities. In the meantime, the only workaround would be to use the CNH templates
Keywords
obx, rehire with old employment, custom object, hire template, Looks like something went wrong. Please try again or contact Product Support, if the problem persists , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem
SAP Knowledge Base Article - Public