Symptom
Candidate gets error message at the Personal Data Collection Step. "Looks like something went wrong. Please try again or contact Product Support, if the problem persists."
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
Replicate Personal Data Collection Steps as a sample candidate.
Cause
One of the cause for this error could be customer has workflow enabled. However, Onboarding does not support workflow on custom objects.
Resolution
Make sure for the customer object, you must set the Show Data Link option to No as currently the support for the workflow is unavailable from Onboarding.
Keywords
OBX, payment information, workflow. , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem