Symptom
After establishing SAC connections, customers will use them to create models and stories. As the time passes, misconfigurations may happen on customer side (eg. changes with backend system host:port).
SAC Users will notice the issue only when using the connection again (creating models, accessing stories). In other words, they will not get notified about SAC connection failure.
Customers may reach SAC Product Support asking for an alert mechanism to identify SAC Connections Failure
Example:
- User created HANA Live connections and HANA DB connections in SAC tenant to their BW HANA DBs.
- They would like to know if there is any alert mechanism if they can get the alert when connection's are broken for any reason.
- This will help them to check and resolve immediately. Instead of noticing the problem when they really need to use connection.
Environment
SAP Analytics Cloud
Cause
SAC currently does not have this feature.
Resolution
Right now, there is no such alert for SAC connections broke.
The connection attempt will occur when:
- 1. You create the connection
- 2. You edit > save the connection
- 3. You use the connection (creating a model, accessing story based in live model, ...)
With these scenarios, SAC sends requests to backend system for connection establishment.
Adding a connection alert for broken connections would need SAC to be constantly reaching ("pinging") the source system. Then, instead of a reactive behavior (SAC tries to connect only when you create/edit/use the connection), it would became a live/real-time behavior (SAC always testing connections).
Imagining SAC tenant with +50 connections (real use case), this constant communication between SAC and source system may flood your Application Servers, Cloud databases, Network with unnecessary requests. And the benefit of knowing exact when connection breaks will have a big cost for customers.
You can describe your feature desire adding details about expected connection type with SAC enhancement request tool.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an incident for SAP Analytics Cloud?
- Search for SAP Analytics Cloud content using Google or Bing:
-
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud > Learning > Data Connections
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAC, connection, notification, error, issue, failure, alert, automatic , KBA , LOD-ANA-ADM , SAC Administration , LOD-ANA-LDC , SAC Live Data Connection , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Problem