SAP Knowledge Base Article - Public

3446593 - "There is a time account with overlapping validity for user" error when updating Time Account entity

Symptom

You are trying to update a Time Account record through import or API, but you are facing an error similar to the below:

"There is a time account with overlapping validity for user XXXXX and time account type YYYYY"

Usually, the external code of the Time Account record referred is also indicated in the error message.

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HXM Suite

Cause

In short, the error message means you are trying insert a Time Account record which overlaps the validity (period between the startDate and endDate) of another Time Account record (indicated by external code, user and account type).

Resolution

Based on the external code, user and account type indicated, check the Time Account record referred and correct the data being imported that overlaps its validity.

Keywords

time, account, overlap, overlapping, validity, user, error, update, updating, upsert, upserting, import, importing, edit, editing , KBA , LOD-SF-EC-TIM-TA , Time Accounts (TAT, TA, TAD) , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , Problem

Product

SAP SuccessFactors HCM Suite all versions