SAP Knowledge Base Article - Public

3446616 - onChange rule is triggered twice for field company, when company field is changed by another onChange rule

Symptom

An onChange rule for field Company, which triggers an error message is triggered twice when company field is changed by another onChange rule.

Environment

SAP SuccessFactors Employee Central - Job Information

Reproducing the Issue

Prerequisite - Configured Position to Job information Sync rule as onChange and onChange Rule for field Company, which triggers an error message when Company is changed. 

  1. Navigate to employee profile and edit Job Information.
  2. Change existing position to New Position for the user.
  3. onChange rule triggers.
  4. Click “OK” to the error message that comes up twice to proceed.

Cause

  • As per the onChange rule "PositionToJobPropagation" of Position field when the position value is not null then the Company field is setting with a value and because of this the onChange (ERROR) rule configured in Company field is triggered for the first time.
  • The reason for the second time to display the error message is because of the security call (onFieldChangeForLegalEntity) for the legal entity field which is expected security call for all the legal entity fields (Example: Company). 

Resolution

Engineering Team have confirmed that to not configure rule for legal entity [Company] fields which raises an Error message.

Keywords

INC7592416, legal entity, company, position, onChange, rule, raise, error, message, ok, twice, job information, position to job information, sync, change, ECT-233953 , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions