SAP Knowledge Base Article - Public

3446864 - Error message: "The steps cannot be loaded. Please try again later" in Purchasing Documents

Symptom

'The steps cannot be loaded. Please try again later' error is raised in the approval details of Purchasing apps.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the respective document management application (e.g., Manage Purchase Requisitions, Manage Purchase Orders).
  2. Search for and open the affected purchasing document.
  3. Navigate to the Approval Details section to review the current workflow status and step sequence.

Cause

No active workflows in Manage Workflows for Purchase document apps. (Ex: manage workflow for purchase Requisitions, manage workflow for purchase order etc.)

Resolution

A supporting workflow must be configured or, at a minimum, the "Automatic Release" scenario must be activated. This configuration is performed within the specific "Manage Workflows" application corresponding to the document category.

Keywords

MM-FIO-PUR-REQ-PRF, MM-FIO-PUR-REL, S4_PC, S4_1C, S4HC, X4BC, Manage workflows app, error in approval details, The steps cannot be loaded. Please try again later, active workflow, release item , KBA , MM-FIO-PUR-REL-2CL , Fiori UI for Purchasing Approval (Public Cloud) , MM-FIO-PUR-REQ-PRF , Manage Purchase Requisitions – Professional , Problem

Product

SAP S/4HANA Cloud Public Edition all versions