SAP Knowledge Base Article - Public

3447158 - Business Character CRM000 must exist only once for business partner CRM000

Symptom

C4C Error for BP replication from S4:

 "message": "Failed to process the inbound message.",
    "details": [
        {
            "code": "400",
            "message": "{\"error\":{\"message\":\"Business Character CRM000 must exist only once for business partner CRM000.\",\"code\":\"sap.crm.md.service.businessPartnerService.businessPartnerMessage.businessCharacterForBusinessPartnerNotUnique\"}}

Environment

Product version: SAP Sales Cloud and SAP Service Cloud Version 2 1.0

Reproducing the Issue

  1. Go to Settings
  2. Open the Message Monitoring
  3. check the respective erroneous message for Business Partner

Cause

1) In standard only one customer role is supported in C4C V2 system.
2) However, in this failed case- you are sending two different customer like roles CRM000 and FLCU00 in the payload.
3) We condense only in case the same role is sent twice. So, if you use value mapping and map those two codes to the same code, then we'll condense it.
4) In your case as you have mapped both roles to different local role codes - this error is triggered.

Resolution

To fix this issue, you can filter the roles in DRFF so that only one customer role(standard CRM000) will be sent to C4CV2. When delta message is sent from V2 to S4 , the roles in S4 will remain untouched provided if you configure the integration according to documentation.

See Also

An alternative solution to DRF filter:

We condense only in case the same role is sent twice. So, if they use value mapping and map those two codes to the same code, then we'll condense it.

Keywords

Business Character CRM000;CRM000;businessCharacterForBusinessPartnerNotUnique;businessPartnerS4ReplicationMessageIn  , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Known Error

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0