SAP Knowledge Base Article - Public

3447178 - Custom field not available in Purchase Order API V4

Symptom

A new custom field has been created for Procurement: Purchasing Document (MM_PURDOC_HEADER) and Procurement: Purchasing Document Item (MM_PURDOC_ITEM).
However, after successfully publishing the custom field, it remains invisible when executing API CE_PURCHASEORDER_0001.

"Image/data in this document is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."  

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open the Custom Fields app.
  2. Navigate to the Custom Fields section and create a new custom field for the Procurement: Purchasing Document (MM_PURDOC_HEADER) or Procurement: Purchasing Document Item (MM_PURDOC_ITEM).
  3. Save and publish the newly created custom field.
  4. Execute the GET method for API CE_PURCHASEORDER_0001.
  5. Inspect the response and observe that the custom field does not appear in the response.

Cause

Missing custom field enablement for API.

Resolution

Enable the custom field for API OData service for PurchaseOrder and PurchaseOrderType :

See Also

Purchase Order Create, update, or delete purchase orders using this synchronous service

Purchase Order (OData V4)

Keywords

Purchase Order API, Custom Field, ODATA, V4 , KBA , MM-PUR-PO , Purchase Orders , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions

Attachments

Pasted image.png