Symptom
In the Ticket Advanced Search when you filter the Assigned To field by selecting any employee from the OVS, the field in the Advanced Search is showing in ID instead of the name of the Employee.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Go to Service Work Center
- Go to Tickets View
- Open Advanced Search
- Click on the Value Help button and choose any Employee
- On the Advanced Search the Assigned To is displaying the ID of the Employee instead of Name
Cause
You are using the OVS type of Assigned To field. The OVS field always displays the ID of the Assigned To field after Employee selection from the OVS. This is the system expected behavior.
Resolution
We provide 2 "Assigned To" fields type in the Ticket Advanced Search.
You can use the field as per your requirement by adding the field from adaptation mode. You can add the field by:
- Go to Service Work Center
- Go to Tickets view
- Start Adaptation Mode
- Open Advanced Search
- Edit the Advanced Search in adaptation mode and select the Assigned To field type as per your requirement.
Type 1 - This is a Free Text field. In this field you can search using name and this displays the Processor Formatted Name.
In this field you can also enter your search filter like *ABC*. Based on this filter, the search will return all Tickets which has Assigned to field containing *ABC* along with other Preceding/Succeeding name. (Where ABC is the first/middle/last name)
Type 2 - This is an OVS field and this field will always display the ID of the selected Employee/Processor.
You can select one Employee from the Value help in this field and the search will give the result based on the ID of the selected Employee.
You can also select multiple Employees in this field using the "More Options" button. This will allow you to select multiple Employee IDs by using the "Add (+)" operator.
This is the current system behavior. If you want a change in this existing behavior, please post your idea on the influence portal using the link Influence Opportunity Homepage - Customer Influence (sap.com)
Keywords
Ticket , Advanced Search , Assigned To , ID , Name , OVS , KBA , LOD-CRM-SRP , Service Request Processing , How To