SAP Knowledge Base Article - Public

3447570 - Unable to Edit and Save changes (Screen Freeze) in Manage Job Profile Templates

Symptom

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental 

Unable to edit the contents of Job Profile Template and save the changes done.
Unable to save(Screen will freeze/Load forever) in Manage Job Profile Templates.


Environment

SAP SuccessFactors Job Profile Builder

Reproducing the Issue

1. Login to Impacted Instance
2. Go to Manage Job Profile Templates
3. Click on the impacted template
4. Edit some of the section and click I'm Done(Save)
5. Screen will load forever/Screen will freeze.

Cause

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Cause
Position Title/ Job Title should be in the correct place(First in order of the template). As seen in the Network Trace as a prompted error.


In trying to check on what's causing the issue. You may open the Network Trace(Upon being on the impacted page, before saving/clicking I'm Done) right click and select Inspect.
You may also just go to the triple dot of your environment(Google Chrome) and open Developer Tools.

Go to Network > Clear the network log > Reproduce the issue in the impacted page(screen freeze) > It will prompt in the Preview the cause (Error "Position title must in first order")

Resolution

To Resolve the issue. 

You must follow what is being prompted in the network trace. Mainly putting/setting up the configuration of your template in the Correct Order. (Putting Job Title/ PositionTitle in the first order of your template).

You may edit a current impacted Template via going to Manage Data (Job Template > Targeted template to correct)

Click on Take Action > Make correction

Position the Job Title to be in the first order



Save changes. Then now go and try to edit and save in the impacted job profile template in Manage Job Profile Template ( this should resolve the issue ).

*IMPORTANT TO KNOW
In editing the data, there might be a scenario where your Job Title is not really a Position Title (To know, you may click on the details and check ContentType whereis this should be POSITIONTITLE) if this is a different one let's say LONGDESCRIPTION you may want to create a new template with the proper section and configuration(Job Title/Position title be in first in the order).

Keywords

Save, Edit, Unable to Save, Job Profile Template, Screen Freeze, Frozen screen, Loading forever, Can't edit, Can't save, Manage Job Profile Template , KBA , LOD-SF-TIH-JPB , Job Profile Builder , Problem

Product

SAP SuccessFactors HXM Core 2311