Symptom
In the Personnel File of an Employee, the Second Last Name of e.g. a Danish Employee cannot be maintained or edited. This is possible for First and Last Name only. There is no field for Second Last Name, not even via Personalization/Key User Tools.
This happens, even after the Employee was migrated via Migration template in Business Configuration and a value for Second Last Name field was maintained in the import file.
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to the Personnel Administration work center
- Go to Employees view
- Search for and find the employee
- Click on Edit
- Navigate to the Personal Data tab
- Navigate to Biographical Data subtab
- There is no option to see or edit the Second Last Name
Cause
According to the info in the standard migration template, Second Last Name is only relevant in some countries.
The employee is associated with a country where only one last name is allowed
Resolution
Check the correctness of the names provided, and verify the possibilities offered by the law of the respective country, like e.g. combining last names with a hyphen, to make it one name.
Keywords
not possible, import, not available , KBA , SRD-HR-PAD , Personnel Administration , Problem