Symptom
- Date format for objects under the Agent Desktop -> Entity tab -> Table View shown with English Date format while logged on in Dutch
- The expectation is to see the dates as DD/MM/YYYY instead of MM/DD/YYYY
Environment
- SAP Service Cloud Version 2 1.0
- SAP Sales Cloud Version 2 1.0
Reproducing the Issue
- Connect to Service Cloud in Dutch
- Open the Agent Desktop
- Open and confirm a Business Partner
- Click on (Entiteiten) Entities -> Table View
- Look at "Referentiedatum" or any field related to dates; notice the date is shown as MM/DD/YYYY and should be DD/MM/YYYY
Cause
- 3rd party
- Browser settings
Resolution
- To ensure consistency, ensure that the browser locale is correct, the locale is used to determine the dates, time zone, or amount formats.
- Verifying the existing browser language via the Developer tool console
- Go to the Case Work Center
- Right click and click on "Inspect" or hit Ctrl+Shift+I (English 101 keyboard)
- At the end of the console, enter the following commands:
- window.auth4crm.AuthUtil.getLocale() [Hit enter] -> the default browser language should be displayed.
- Intl.DateTimeFormat().format(new Date()) [Hit enter] -> this will show the current date format
- If you want to use English as the language, but want to still have the same DD/MM/YYYY format with 24 hour time format, then you need to set the preferred browser language as "English (United Kingdom)".
- For example, in Google Chrome:
- Go to Settings
- Search for "Preferred Languages"
- Add/Select "English (United Kingdom)" and make it as the default UI language
- This language is used to display the Google Chrome UI)
- This language should also be at the top if there are other languages in the list
- Restart the browser and retest
- For Microsoft Edge:
- Access Settings: Click on the three-dot menu icon (⋯) located in the top right corner of the browser window to open the menu.
- Navigate to Settings: In the menu, scroll down and click on "Settings".
- Select Language Settings: In the Settings menu, scroll down and click on "Languages".
- Add Preferred Language: Click on "Add languages". For example, English UK/GB
- Choose Language: Select your preferred language from the list of available languages. You can search for the language using the search box or scroll through the list.
- Set as Preferred: After selecting the language, click on the "Add" button to add it to your list of preferred languages.
- Adjust Language Settings: Once added, you can click on the language to adjust settings such as the display language order and spell check preferences.
- Save Changes: After making your desired changes, click on the "Save" button to save your language preferences.
- Restart Microsoft Edge: Close and reopen Microsoft Edge for the changes to take effect.
- For example, in Google Chrome:
- Verifying the existing browser language via the Developer tool console
- Please note though, that for add-ons, dates and times are not updated based on your browser settings.
- In the operating system itself, ensure that the preferred language is defined as the display language
See Also
Keywords
Language, Date, Format, day, month, number, decimal, time, Local, Language, DD/MM/YYYY, English, MM/DD/YYYY , KBA , CEC-CRM-AD , Agent desktop - live channels , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0