Symptom
When you add a new Product into a Sales Order or Service Order, you see error "Product ABC not valid; it is blocked" (Where ABC Represents the ID of the Product) and the document becomes inconsistent.
Environment
SAP Business ByDesign
Reproducing the Issue
Using a Service Order as an example:
- Go to the Service Order Processing work center.
- Open the Service Orders view.
- Find and open Service Order DEF (Where DEF Represents the Service Order ID).
- Click the View All button.
- Navigate to the Service and Spare Parts tab
- Add Item ABC by inputting it's ID in a new Line Item.
The system will display error "Product ABC not valid; it is blocked"
Cause
This error is raised when the Product is Blocked for the particular Sales Organization and Distribution Channel used in the Sales Order or Service Order.
Resolution
You can correct the Blocked status by following these steps:
- Go to the Product and Service Portfolio work center.
- Open the Products view.
- Find and Edit Product ABC.
- Click the View All button.
- Navigate to the Sales tab.
- Under Distribution Chains, find the pair of Sales Organization and Distribution Channel used in Sales/Service Order DEF.
- Change the status of the Distribution Chain from 'Blocked' to 'Active'.
- Save the Product.
Keywords
Blocked, Blocking, Block, Product, Material, Masterdata, Master data, Sales Order, Service Order, Error, Issue, Impossible, Unable, Error, Inconsistent, Red, Not Valid, Invalid. , KBA , AP-SLO-SO , Sales Order , AP-SVO-SO , Service Order , How To