Symptom
The Process Communication Error "Cancellation reason XX is not valid" is displayed in the Document Flow tab of a Sales Order document.
Environment
Reproducing the Issue
- Go to the Sales Order Work Center.
- Go to the Sales Orders View.
- Filter for All Orders.
- Search for the Sales Order XYZ (XYZ represents the Sales Order ID).
- Open, Select View All.
- Navigate to the Document Flow tab.
The Process Communication Error is displayed for the Sales Order XYZ.
Cause
The Process Communication Error "Cancellation reason XX is not valid" occurs because the items in the Sales Order document were rejected with a Reason for Rejection Code that is no longer valid in the system.
In order to check the Reason for Rejection Codes that are currently valid in the system, the following steps can be performed:
- Go to the Business Configuration Work Center.
- Go to the Overview View.
- In the search field, search for Reasons for Rejection.
- Open the Reasons for Rejection activity.
The valid Reason for Rejection Codes are displayed in the UI.
Resolution
In order to remove the Process Communication Error from the Sales Order document, the following solutions can be applied:
Option 1 - Change the Reason for Rejection for the Line Items to a valid option.
- Go to the Sales Order Work Center.
- Go to the Sales Orders View.
- Filter for All Orders.
- Search for the Sales Order XYZ.
- Open, Select View All.
- Navigate to the Items tab.
- Mark the Line Items YY (YY represents Line Item Number).
- Change the Reason for Rejection to a valid value.
- Select Save button.
Perform the same for other line items which have the same invalid Reason for Rejection Code in the Sales Order XYZ.
Option 2 - Restore the Reason for Rejection Code in the 'Reasons for Rejection' activity
Note: This option can only be applied if a Default Reason for Rejection Code was deleted in the system. If a custom Reason for Rejection Code was deleted in the system, then we kindly recommend to apply the "Option 1" as the custom Reason for Rejection Code can no longer be restored.
- Go to the Business Configuration Work Center.
- Go to the Overview View.
- Search for Reasons for Rejection.
- Open.
- Select Restore Defaults button.
- Mark the Key for the Default Reason for Rejection Code.
- Select Restore button.
- Select Save and Close.
After one of the above processes is performed in the system, we kindly ask you to open a case in order for SAP support to perform a backend correction to remove the Process Communication Error from the Sales Order document.
See Also
KBA 3452802 - The Error "Cancellation reason XX is not valid" is Displayed for a Sales Order (Internal)
Keywords
cancellation reason, is not valid, valid, items, reason for rejection, sales order, process communication error , KBA , AP-SLO-SO , Sales Order , How To