SAP Knowledge Base Article - Public

3448900 - Error "App could not be opened because the SAP UI5 component of the application could not be loaded." when opening a custom app - SAP S/4HANA Cloud

Symptom

Error "App could not be opened because the SAP UI5 component of the application could not be loaded." when opening a custom app.

From the browser console, error "403 Forbidden The request has been blocked by UCON." displays.

Sample error message: 

App could not be opened because the SAP UI5 component of the application could not be loaded.

Failed to load UI5 component for navigation intent "#YY1_SUPPLIER-maintain"
 
 

Environment

SAP S/4HANA Cloud

Cause

It might caused by uncompleted transport of the related custom catalog extensions and business catalogs.

Resolution

1. Check the related software collection, status like "Imported Successfully, Postprocessing Failed" can be found. 

2. Check via T-code ATO_CLOUD_SUPPORT, errors like below can be found.

    Task CE-0035-Generate Business Roles stopped with status Failed; appl. component BC-SRV-APS-IAM        
    Restriction type FAGL_ACTIV_BUKRS is not valid for business role ZD_FN_GL_ACCOUNTANT_GL1_AU09
 
3. To solve the transport issues: 

    3.1. In test system, do the dummy changes to the business roles which were shown in the error messages.

    3.2. Involve them into the software collection.

    3.3. Export it from Test system.

    3.4. Import the new version of the software collection. 

4. After the import completes successfully, check the custom app again.

Keywords

App could not be opened because the SAP UI5 component of the application could not be loaded, custom app, could not open, UI5, Cloud , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions