SAP Knowledge Base Article - Public

3449411 - Sales Order API error messages doesn't contain item info - S/4HANA Cloud

Symptom

When V2 API API_SALES_ORDER_SRV is called to create a sales order with some items. The errors returned by API are not bound to specific items. It is quite difficult for user to identify which item is causing the issue.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Call V2 API API_SALES_ORDER_SRV to create a sales order with some items
  2. When some errors are retuned by the API, the errors are are not bound to specific items, so it is not clear which item has the issue.

Cause

Missing feature in V2 API API_SALES_ORDER_SRV.
https://api.sap.com/api/API_SALES_ORDER_SRV/overview

Resolution

As a workaround

The new version of the API (ODataV4 CE_SALESORDER_0001) has specific error handling and the specific error is bound to specific item. It is clearly visible, where the error comes from.

https://api.sap.com/api/CE_SALESORDER_0001/overview

Keywords

KBA , SD-SLS-API-2CL , API (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition 2402