Symptom
The Delivery status of an item is being displayed as "In Progress" even though the overall status of the Sales Order is "Completed".
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Order Work Center.
- Go to the Sales Order View.
- Filter for All Sales Orders.
- Search for the Sales Order ID XYZ. (where XYZ represents the Sales Order ID)
- Open, Select View All.
- Navigate to the Items tab.
- Mark the Line Item XX. (where XX represents the Line Item number)
- Navigate to the Document Flow tab.
The Delivery status of the item is displayed as "In progress" and the Invoice status is displayed as "Not Started".
In addition, the Delivery process is occurring through a 3PL document.
Cause
In this case, the 3PL request is rejected which cause the status of the document to change to "Finished". Therefore, the Delivery status of the Item will be kept as "In Progress" in order to indicate that the Delivery of the item has started at some point for the Sales Process of the document.
Even after maintaining a Reason for Rejection for the Line Item, the Delivery status will continue to be displayed as "In Progress". This occurs because once the Reason for Rejection is set for the item, the system will identify that this action has completely stopped the Delivery process for the Item and will keep the status as "In Progress" for reference.
In addition, the warning message "Item XX: Cancelled item may already be in process; stop delivery/execution" will be displayed after setting the reason for rejection for the Item.
Additionally, to verify the item cancellation status, you can check in Sales Order Volume report, show the Cancellation Status (Item) field in the view.
Resolution
This is a standard system behavior.
Keywords
3pl, sales order, delivery status, in progress, item, finished, rejected, canceled. , KBA , AP-SLO-SO , Sales Order , How To