SAP Knowledge Base Article - Public

3449463 - Tasks are not triggered to the candidate - Onboarding

Symptom

  • Email is not being triggered to the candidate
  • No task in data collection can be seen from the onboarding dashboard for the affected candidate

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login to instance
  2. Go to Onboarding dashboard > Search the candidate
  3. No Data Collection. 
  4. Additionally, go to Email Status
  5. No External User Welcome Email triggered to the candidates

Cause

  • Undeployed BPE
  • Outdated Processes in PVM

Resolution

After each release, you can update the existing active Onboarding workflows in Process Variant Manager to incorporate enhancements and changes.

Once activated in the Process Variant Manager, the updated workflows will be automatically deployed in the Business Process Engine.

You can easily customize the steps and activate the workflow of the newly created processes by updating the process variant.

Observation:

If the issue still persists, try the following steps:

  1. Go to "Update Process Flows for Onboarding and Offboarding page"
  2. Select the desired BPE user
  3. Click to update the flow

See Also

3023715 - [Onboarding] Updating a Process Variant (Onboarding/Offboarding)

Keywords

bpe, deploy, process, process, variant, email, tasks, data, collection, task, triggered, obx, onboarding, update, external, user , KBA , LOD-SF-OBX-BPE , BPE Process Flow , How To

Product

SAP SuccessFactors Onboarding all versions