Symptom
The candidate is not receiving the email notification, and no tasks related to data collection are visible on the Onboarding Dashboard for the affected candidate.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login to instance
- Go to Onboarding dashboard > Search the candidate
- No Data Collection.
- Additionally, go to Email Status
- No External User Welcome Email triggered to the candidates
Cause
- Undeployed BPE
- Outdated processes present in Process Version Management (PVM)
Resolution
After each release, existing active Onboarding workflows can be updated in the Process Variant Manager to incorporate enhancements and changes.
Once activated in the Process Variant Manager, the updated workflows are automatically deployed in the Business Process Engine.
Steps can be easily customized, and the workflow for newly created processes can be activated by updating the process variant.
Observation:
1. If the issue persists, the following steps should be performed:
2. Navigate to the "Update Process Flows for Onboarding and Offboarding" page.
3. Select the appropriate BPE user.
4. Click the update flow button to refresh the process.
See Also
3023715 - [Onboarding] Updating a Process Variant (Onboarding/Offboarding)
Keywords
bpe, deploy, process, process, variant, email, tasks, data, collection, task, triggered, obx, onboarding, update, external, user , KBA , LOD-SF-OBX-BPE , BPE Process Flow , Problem
SAP Knowledge Base Article - Public