Symptom
The e-mail(s) is removed from the Timeline/Interactions facet in the ticket when the Contact is removed by Personal Data Removal.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Send an E-mail to an e-mail channel to create a ticket (From E-mail must be maintained in a Contact)
- Go to the Service work center
- Go to the Ticket view
- Open the ticket 123 (Where 123 refers to the Ticket ID and this is created at step 1)
- Click the Contact in the Overview facet
- Click the Actions
- Click Set as Obsolete
- Go to the Data Protection and Privacy work center
- Go to the Personal Data Removal view
- Search for the Contact
- Select the Contact and click Remove Data
- Go back to the Ticket view
- Open the ticket 123
- Go to the Timeline/Interactions facet
Result: The e-mail is removed.
Cause
Missing scoping in the Business Configuration.
Resolution
Scope the question "During personal data removal, do you want to retain the transactional data and remove only the personal data of contacts and employees?".
Steps
- Go to the Business Configuration work center
- Go to the Implementation Projects view
- Select the current Project
- Click Edit Project Scope
- Click Next till 4 Questions
- Expand Built-in Services and Support
- Expand System Management
- Click Security
- The question is in Data Privacy
- Tick In Scope box
- Save the change
Keywords
e-mail, email, missing, remove, privacy, data, contact, timeline, interaction, personal, data, removal , KBA , LOD-CRM-SRP-INT , Ticket Interactions , Problem
Product
SAP Cloud for Customer core applications 2402