Symptom
When trying to add a custom party role created to any of your opportunity party schemas, you notice the role is not available to be selected.
Environment
- SAP Sales Cloud Version 2
- SAP Sales and Service Cloud Version 2
Reproducing the Issue
- Click on the User Menu.
- Click Settings.
- Navigate to All Settings.
- Click Party Roles, under Party Processing.
- Create a new custom party role, adding all relevant details.
- Save the changes.
- Click Party Schema, under Opportunities.
- Select any schema.
- Click Edit.
- Click on the + icon to add a new custom party role.
- See the party created is not displayed.
Cause
The custom party role was created with a Category which is not supported for the opportunity party schema, hence, it is not available to be selected.
Resolution
At the moment, the following party role categories are supported for opportunity party schema:
• Custom Organizational Unit Party
• Custom Account Party
• Customer Contact Person Party
• Custom Employee Party
When creating a custom party role, ensure that one of the above categories are selected, so that the party will be available for selection.
See Also
Keywords
Party Schema, Opportunity, Custom Party Role, Sales, Custom Employee Party, Customer Contact Person Party, Custom Account Party, Custom Organizational Unit Party. , KBA , CEC-CRM-GS , Guided Selling/Opportunity for SAP Sales/Service Cloud , CEC-CRM-PAP , Party Processing for SAP Sales/Service Cloud , How To