Symptom
Some Contacts are not visible when segmented on Language Code
Environment
SAP Marketing Cloud Edition
Reproducing the Issue
- Logon to your SAP Marketing Cloud tenant
- Go to the segmentation app
- Create a new segment using All contacts profile
- Select Language Code attribute
Cause
Incorrect Attribute selected
Resolution
- IC_LANGUAGE_CODE belongs to Accounts Attribute Group in standard tenant (although it can be changed to a different Attribute Group), but here LANGUAGE_CODE, that belongs to Contacts attribute group, must be used instead
- The configuration change must take place on the Quality system first and then imported to the Production tenant
- The attributes must be "Visible as Attribute"
See Also
Keywords
Attribute Visibility,IC_LANGUAGE_CODE, SAP_CONTACT_ENGAGEMENT_SIN , KBA , CEC-MKT-SEG , Segmentation , Problem
Product
SAP S/4HANA Cloud Public Edition 2402