Symptom
- (ONB) Prepare for New Team Member email is getting sent several times to the manager.
- Trigger: (ONB) Prepare for New Team Member Trigger
Environment
SAP SuccessFactors Onboarding
Cause
Configuration issue:
- There are two templates configured with Trigger Condition '(ONB) Prepare for New Team Member Trigger' under NHA Category.
- To confirm there are two templates triggered for the same NHA Task, navigate to Manage Data > EmailMessage.
- Enter the sample candidate's email Activity ID that can be captured from Email Services > Email Status
- See that there were two results.
- Same NHA task, but two different templates.
Resolution
- There are 2 templates configured, hence, email is triggered twice for each tasks.
- To fix the issue, please remove/inactivate one of the configured template.
- There should only be one active template.
- Once this is done, please ensure that you update BPE XML via Update Process Flows for Onboarding and Offboarding and then run metadata refresh.
- And lastly, check with a new candidate.
See Also
Keywords
Email Services, Email Status, (ONB) Prepare for New Team Member Trigger, Multiple Email Triggered, NHA Category, Onboarding, ONB, OBX, ONB2, Onboarding 2.0 , KBA , LOD-SF-OBX-EML , Notifications , Problem
Product
SAP SuccessFactors Onboarding 2311