SAP Knowledge Base Article - Public

3450267 - Not able to change user role in SAP Analytics Cloud (SAC) via PUT request using API.

Symptom

Error : { "schemas": [ "urn:ietf:params:scim:api:messages:2.0:Error" ], "status": "400", "scimType": "invalidValue", "detail": "Request is unparsable, syntactically incorrect, or violates schema."} when creating/modifying the user in SAC via POSTMAN API.

Environment

SAP Analytics Cloud

Reproducing the Issue

  1. Create a POST request for URL for SAC tenant
  2. Add the HTTP Headers
  3. Write the required script in response body for creating/modifying the user.

Notice the error : 

{ "schemas": [ "urn:ietf:params:scim:api:messages:2.0:Error" ], "status": "400", "scimType": "invalidValue", "detail": "Request is unparsable, syntactically incorrect, or violates schema."}

Cause

All the available licenses have already been used by the user due to which the API couldn't modify the user. 

Resolution

Once the exceeding user is deactivated/deleted, you will be able to use API make the change/modify user. Or, consider purchasing more licenses.

See Also

Keywords

API, SAC, user , activated, deactivated, licenses, modify, change, schemas, invalid values , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud all versions